닥북 모음집 2.0 설치 오류

닥북 활용에 대한 모든 질문과 답변

닥북 모음집 2.0 설치 오류

전체글글쓴이: sunyoung » 2012-08-27 5:48 pm

닥북 모음집 설치시, 계속해서 설치 오류가 나타나네요.
예전에 다운 받았던것을 삭제하고, 다시 설치하는건데 오류가 나네요;

- 오류 : could not open file 'files/fop-1.0-bin.zip

files/fop-1.0-bin.zip에서 수동으로 압축 푸려고 해도 안되요.
'지원하지 않는 포맷입니다.'라고 나타나요.

왜 이런건지 알려주세요.
sunyoung
사용자
 
전체글: 2
가입일: 2012-08-02 2:03 pm

전체글글쓴이: 류광 » 2012-08-27 6:45 pm

안녕하세요~ 확인해 보았더니 fop-1.0-bin.zip 다운로드 URL이 변경되었었습니다.

installer 폴더의 dbkspec.lua 를 아무 텍스트 편집기로 열어서,
코드: 모두 선택
   url='http://apache.mirror.cdnetworks.com/xmlgraphics/fop/binaries/fop-1.0-bin.zip',


코드: 모두 선택
   url='http://www.apache.org/dist/xmlgraphics/fop/binaries/fop-1.0-bin.zip',

로 바꾸어서 저장하세요.

그런 다음 installer/files 에서 fop-1.0-bin.zip을(그리고 혹시 fop-1.0-bin.zip.done이 있으면 그것도) 삭제하고, 다시 install.bat을 실행해 보세요.

설치 구성요소의 다운로드 URL이 바뀔 때마다 이런 일이 발생하는데요. 조만간 저 dbkspec.lua 자체를 닥북 한국 홈페이지에서 자동으로 내려받아서 적용하는 쪽으로 설치 프로그램을 개선할 생각입니다.
류광
사용자
 
전체글: 432
가입일: 2003-12-27 12:02 am

전체글글쓴이: 류광 » 2012-08-27 7:03 pm

http://docbook.kr/release/dbkspec.lua 에 갱신된 dbkspec.lua 파일을 올려 두었습니다. fop-1.0 외에, 언제 없어질 지 모르는 kldp.net 쪽 URL 역시 적절히 대체했습니다.

installer/ 디렉터리에 덮어 쓰면 됩니다.
류광
사용자
 
전체글: 432
가입일: 2003-12-27 12:02 am

전체글글쓴이: 류광 » 2012-12-17 9:58 pm

갱신된 dbkspec.lua를 포함한 새 버전을 http://docbook.kr/phpBB2/viewtopic.php?topic=879 에 올려 두었습니다.
류광
사용자
 
전체글: 432
가입일: 2003-12-27 12:02 am


다시 돌아감: 질문과 답변

접속 중인 사용자

이 포럼에 접속 중인 사용자: 접속한 회원이 없음 그리고 손님들 3 명

cron